aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/vulkanunderqml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/vulkanunderqml/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/vulkanunderqml/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/quick/scenegraph/vulkanunderqml/CMakeLists.txt b/examples/quick/scenegraph/vulkanunderqml/CMakeLists.txt
index 6921427d1b..8e4c3d346c 100644
--- a/examples/quick/scenegraph/vulkanunderqml/CMakeLists.txt
+++ b/examples/quick/scenegraph/vulkanunderqml/CMakeLists.txt
@@ -1,29 +1,21 @@
-# Generated from vulkanunderqml.pro.
-
cmake_minimum_required(VERSION 3.16)
project(vulkanunderqml LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/scenegraph/vulkanunderqml")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
qt_add_executable(vulkanunderqml
main.cpp
vulkansquircle.cpp vulkansquircle.h
)
+
set_target_properties(vulkanunderqml PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
@@ -31,6 +23,7 @@ set_target_properties(vulkanunderqml PROPERTIES
# Prevent name clash with build subdirectory on case-insensitive file systems
OUTPUT_NAME vulkanunderqmlapp
)
+
target_link_libraries(vulkanunderqml PUBLIC
Qt::Core
Qt::Gui