aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/tableview/pixelator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/tableview/pixelator/CMakeLists.txt')
-rw-r--r--examples/quick/tableview/pixelator/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/examples/quick/tableview/pixelator/CMakeLists.txt b/examples/quick/tableview/pixelator/CMakeLists.txt
new file mode 100644
index 0000000000..23e730772a
--- /dev/null
+++ b/examples/quick/tableview/pixelator/CMakeLists.txt
@@ -0,0 +1,56 @@
+# Generated from pixelator.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(qml_pixelator LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/quick/tableview/pixelator")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS Qml)
+
+add_qt_gui_executable(qml_pixelator
+ imagemodel.cpp imagemodel.h
+ main.cpp
+)
+target_link_libraries(qml_pixelator PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(qmake_immediate_resource_files
+ "main.qml"
+ "qt.png"
+)
+
+qt6_add_resources(qml_pixelator "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ ${qmake_immediate_resource_files}
+)
+
+install(TARGETS qml_pixelator
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)
+
+set_target_properties(qml_pixelator PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI ImageModel
+)
+
+qt6_qml_type_registration(qml_pixelator)