aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/tutorials/samegame/samegame1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/tutorials/samegame/samegame1/CMakeLists.txt')
-rw-r--r--examples/quick/tutorials/samegame/samegame1/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/examples/quick/tutorials/samegame/samegame1/CMakeLists.txt b/examples/quick/tutorials/samegame/samegame1/CMakeLists.txt
new file mode 100644
index 0000000000..ad791d77b5
--- /dev/null
+++ b/examples/quick/tutorials/samegame/samegame1/CMakeLists.txt
@@ -0,0 +1,51 @@
+cmake_minimum_required(VERSION 3.16)
+project(samegame1 LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/tutorials/samegame/samegame1")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS Qml)
+
+qt_add_executable(samegame1
+ main.cpp
+)
+set_target_properties(samegame1 PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+qt_add_qml_module(samegame1
+ URI samegame
+ VERSION 1.0
+ QML_FILES
+ "Block.qml"
+ "Button.qml"
+ "samegame.qml"
+ RESOURCES
+ "pics/background.jpg"
+ "pics/redStone.png"
+)
+
+target_link_libraries(samegame1 PRIVATE
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+install(TARGETS samegame1
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)