aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/chattutorial/chapter1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols2/chattutorial/chapter1/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/chattutorial/chapter1/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/examples/quickcontrols2/chattutorial/chapter1/CMakeLists.txt b/examples/quickcontrols2/chattutorial/chapter1/CMakeLists.txt
index 4b8770a83d..17587b9ba8 100644
--- a/examples/quickcontrols2/chattutorial/chapter1/CMakeLists.txt
+++ b/examples/quickcontrols2/chattutorial/chapter1/CMakeLists.txt
@@ -1,21 +1,20 @@
cmake_minimum_required(VERSION 3.16)
project(chapter1 LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quickcontrols2/chattutorial/chapter1")
-find_package(Qt6 COMPONENTS Core Gui Qml Quick)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
qt_add_executable(chattutorial-chapter1 WIN32 MACOSX_BUNDLE
main.cpp
)
+
target_link_libraries(chattutorial-chapter1 PRIVATE
Qt::Core
Qt::Gui