aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/swipetoremove/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols2/swipetoremove/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/swipetoremove/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/quickcontrols2/swipetoremove/CMakeLists.txt b/examples/quickcontrols2/swipetoremove/CMakeLists.txt
index c5d6c1ef45..66862b9171 100644
--- a/examples/quickcontrols2/swipetoremove/CMakeLists.txt
+++ b/examples/quickcontrols2/swipetoremove/CMakeLists.txt
@@ -1,38 +1,31 @@
-# Generated from swipetoremove.pro.
-
cmake_minimum_required(VERSION 3.16)
project(swipetoremove LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quickcontrols2/swipetoremove")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml)
qt_add_executable(swipetoremove
swipetoremove.cpp
)
+
set_target_properties(swipetoremove PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(swipetoremove PUBLIC
Qt::Core
Qt::Gui
Qt::Qml
)
-
# Resources:
set(qmake_immediate_resource_files
"fonts/fontello.ttf"