aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/texteditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols2/texteditor/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/texteditor/CMakeLists.txt13
1 files changed, 3 insertions, 10 deletions
diff --git a/examples/quickcontrols2/texteditor/CMakeLists.txt b/examples/quickcontrols2/texteditor/CMakeLists.txt
index 187d1a88b4..52851f1b9b 100644
--- a/examples/quickcontrols2/texteditor/CMakeLists.txt
+++ b/examples/quickcontrols2/texteditor/CMakeLists.txt
@@ -1,21 +1,15 @@
-# Generated from texteditor.pro.
-
cmake_minimum_required(VERSION 3.16)
project(texteditor LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quickcontrols2/texteditor")
-find_package(Qt6 COMPONENTS Core Gui Quick QuickControls2)
-find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Quick QuickControls2 OPTIONAL_COMPONENTS Widgets)
qt_add_executable(texteditor WIN32 MACOSX_BUNDLE
documenthandler.cpp
@@ -29,7 +23,6 @@ target_link_libraries(texteditor PUBLIC
Qt::QuickControls2
)
-
# Resources:
set(texteditor_resource_files
"+touch/texteditor.html"
@@ -56,7 +49,7 @@ endif()
if(CMAKE_CROSSCOMPILING)
target_compile_definitions(texteditor PUBLIC
- QT_EXTRA_FILE_SELECTOR="touch" # special case
+ QT_EXTRA_FILE_SELECTOR="touch"
)
endif()