aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/labsanimation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/labsanimation/CMakeLists.txt')
-rw-r--r--src/imports/labsanimation/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
index fa460034f2..cdf50468ac 100644
--- a/src/imports/labsanimation/CMakeLists.txt
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -9,14 +9,13 @@ qt_internal_add_qml_module(labsanimationplugin
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtLabsAnimationPlugin
SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- INSTALL_QMLTYPES
+ PLUGIN_OPTIONAL
SOURCES
plugin.cpp
- qquickboundaryrule.cpp qquickboundaryrule_p.h
PUBLIC_LIBRARIES
Qt::QmlPrivate
Qt::QuickPrivate
+ Qt::LabsAnimationPrivate
)
#### Keys ignored in scope 1:.:.:labsanimation.pro:<TRUE>: