aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/localstorage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/localstorage/CMakeLists.txt')
-rw-r--r--src/imports/localstorage/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
index 305d9ad178..9d7cd13fe0 100644
--- a/src/imports/localstorage/CMakeLists.txt
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -9,15 +9,12 @@ qt_internal_add_qml_module(qmllocalstorageplugin
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QQmlLocalStoragePlugin
SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- INSTALL_QMLTYPES
+ PLUGIN_OPTIONAL
SOURCES
plugin.cpp
- qquicklocalstorage.cpp qquicklocalstorage_p.h
PUBLIC_LIBRARIES
- Qt::CorePrivate
- Qt::QmlPrivate
- Qt::Sql
+ Qt::Qml
+ Qt::QmlLocalStoragePrivate
)
#### Keys ignored in scope 1:.:.:localstorage.pro:<TRUE>: