aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/qtqml/.prev_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/qtqml/.prev_CMakeLists.txt')
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
index 4e17431218..52e6d3e1e0 100644
--- a/src/imports/qtqml/.prev_CMakeLists.txt
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -1,12 +1,12 @@
# Generated from qtqml.pro.
set(module_dynamic_qml_imports
- QtQml.Models
+ QtQml.Models/auto
)
if (QT_FEATURE_qml_worker_script)
list(APPEND module_dynamic_qml_imports
- QtQml.WorkerScript
+ QtQml.WorkerScript/auto
)
endif()
@@ -21,6 +21,7 @@ qt_add_qml_module(qmlplugin
CLASSNAME QtQmlPlugin
SKIP_TYPE_REGISTRATION
IMPORTS ${module_dynamic_qml_imports}
+ PLUGIN_OPTIONAL
SOURCES
plugin.cpp
PUBLIC_LIBRARIES
@@ -30,7 +31,7 @@ qt_add_qml_module(qmlplugin
#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
# CXX_MODULE = "qml"
-# DYNAMIC_QMLDIR = "module QtQml" "plugin qmlplugin" "classname QtQmlPlugin" "typeinfo plugins.qmltypes" "designersupported" "import QtQml.Models"
+# DYNAMIC_QMLDIR = "module QtQml" "optional plugin qmlplugin" "classname QtQmlPlugin" "typeinfo plugins.qmltypes" "designersupported" "import QtQml.Models auto"
# QML_IMPORT_VERSION = "$$QT_VERSION"
# TARGETPATH = "QtQml"
@@ -38,4 +39,4 @@ qt_add_qml_module(qmlplugin
#####################################################################
#### Keys ignored in scope 2:.:.:qtqml.pro:QT_FEATURE_qml_worker_script:
-# DYNAMIC_QMLDIR = "import QtQml.WorkerScript"
+# DYNAMIC_QMLDIR = "import QtQml.WorkerScript auto"