aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/qtqml
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/qtqml')
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt30
-rw-r--r--src/imports/qtqml/CMakeLists.txt31
2 files changed, 61 insertions, 0 deletions
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..e8261aa5c7
--- /dev/null
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from qtqml.pro.
+
+#####################################################################
+## qmlplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlplugin
+ URI "QtQml"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ IMPORTS
+ QtQml.Models
+ QtQml.WorkerScript
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlModels
+)
+
+#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
new file mode 100644
index 0000000000..185116e6ce
--- /dev/null
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from qtqml.pro.
+
+#####################################################################
+## qmlplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlplugin
+ URI "QtQml"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ IMPORTS
+ QtQml.Models
+ QtQml.WorkerScript
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ Qt::CorePrivate # special case
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlModels
+)
+
+#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml"
+# _LOADED = "qml_plugin"