aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/statemachine
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/statemachine')
-rw-r--r--src/imports/statemachine/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/imports/statemachine/CMakeLists.txt b/src/imports/statemachine/CMakeLists.txt
new file mode 100644
index 0000000000..f06fed1765
--- /dev/null
+++ b/src/imports/statemachine/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Generated from statemachine.pro.
+
+#####################################################################
+## qtqmlstatemachine Plugin:
+#####################################################################
+
+add_qml_module(qtqmlstatemachine
+ URI "QtQml.StateMachine"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQmlStateMachinePlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ childrenprivate.h
+ finalstate.cpp finalstate.h
+ plugin.cpp
+ signaltransition.cpp signaltransition.h
+ state.cpp state.h
+ statemachine.cpp statemachine.h
+ timeouttransition.cpp timeouttransition.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:statemachine.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml/StateMachine"
+# _LOADED = "qml_plugin"