aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/testlib/.prev_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/testlib/.prev_CMakeLists.txt')
-rw-r--r--src/imports/testlib/.prev_CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/imports/testlib/.prev_CMakeLists.txt b/src/imports/testlib/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..b7a6ff468a
--- /dev/null
+++ b/src/imports/testlib/.prev_CMakeLists.txt
@@ -0,0 +1,52 @@
+# Generated from testlib.pro.
+
+#####################################################################
+## qmltestplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmltestplugin
+ URI "QtTest"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
+ GENERATE_QMLTYPES
+ SOURCES
+ main.cpp
+ quicktestevent.cpp quicktestevent_p.h
+ quicktestresultforeign_p.h
+ quicktestutil.cpp quicktestutil_p.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::Quick
+ Qt::QuickTestPrivate
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtTest"
+
+set(qml_files
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+
+qt6_target_qml_files(qmltestplugin
+ FILES
+ ${qml_files}
+)