aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/testlib
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/testlib')
-rw-r--r--src/imports/testlib/.prev_CMakeLists.txt53
-rw-r--r--src/imports/testlib/CMakeLists.txt44
2 files changed, 81 insertions, 16 deletions
diff --git a/src/imports/testlib/.prev_CMakeLists.txt b/src/imports/testlib/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..7674568e16
--- /dev/null
+++ b/src/imports/testlib/.prev_CMakeLists.txt
@@ -0,0 +1,53 @@
+# Generated from testlib.pro.
+
+#####################################################################
+## qmltestplugin Plugin:
+#####################################################################
+
+add_qml_module(qmltestplugin
+ URI "QtTest"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::QuickTestPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickTest
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# TARGETPATH = "QtTest"
+# _LOADED = "qml_plugin"
+
+set(qml_files
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.2"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+
+qt6_target_qml_files(qmltestplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index 89dd13ca0a..bbff88e788 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -5,9 +5,11 @@
#####################################################################
add_qml_module(qmltestplugin
- CPP_PLUGIN
URI "QtTest"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
SOURCES
main.cpp
LIBRARIES
@@ -23,24 +25,34 @@ add_qml_module(qmltestplugin
Qt::Test
)
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# TARGETPATH = "QtTest"
+# _LOADED = "qml_plugin"
+
set(qml_files
- TestCase.qml
- SignalSpy.qml
- testlogger.js
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.2"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+# special case begin
+set_source_files_properties(testlogger.js PROPERTIES
+ QT_QML_SOURCE_INSTALL TRUE
)
+# special case end
-add_qt_resource(qmltestplugin qmake_QtTest
+qt6_target_qml_files(qmltestplugin
FILES
${qml_files}
)
-
-qt_install_qml_files(qmltestplugin
- FILES ${qml_files}
-)
-
-
-#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
-# CXX_MODULE = "qml"
-# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
-# OTHER_FILES = "testlib.json"
-# _LOADED = "qml_plugin"