aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/wavefrontmesh
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/wavefrontmesh')
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt5
-rw-r--r--src/imports/wavefrontmesh/plugin.cpp5
2 files changed, 2 insertions, 8 deletions
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
index 85065589ec..7dd97c8056 100644
--- a/src/imports/wavefrontmesh/CMakeLists.txt
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -9,15 +9,12 @@ qt_internal_add_qml_module(qmlwavefrontmeshplugin
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlWavefrontMeshPlugin
SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- INSTALL_QMLTYPES
SOURCES
plugin.cpp
- qwavefrontmesh.cpp qwavefrontmesh.h
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
- Qt::QuickPrivate
+ Qt::LabsWavefrontMeshPrivate
)
#### Keys ignored in scope 1:.:.:wavefrontmesh.pro:<TRUE>:
diff --git a/src/imports/wavefrontmesh/plugin.cpp b/src/imports/wavefrontmesh/plugin.cpp
index eea0db19db..16c40ae8d5 100644
--- a/src/imports/wavefrontmesh/plugin.cpp
+++ b/src/imports/wavefrontmesh/plugin.cpp
@@ -40,10 +40,7 @@
#include <QtQml/qqmlextensionplugin.h>
#include <QtQml/qqml.h>
-#include "qwavefrontmesh.h"
-
-extern void qml_register_types_Qt_labs_wavefrontmesh();
-
+#include <QtLabsWavefrontMesh/private/qqmlwavefrontmeshglobal_p.h>
QT_BEGIN_NAMESPACE
class QmlWavefrontMeshPlugin : public QQmlEngineExtensionPlugin