aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/window/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/window/CMakeLists.txt')
-rw-r--r--src/imports/window/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/imports/window/CMakeLists.txt b/src/imports/window/CMakeLists.txt
new file mode 100644
index 0000000000..1f02b1a380
--- /dev/null
+++ b/src/imports/window/CMakeLists.txt
@@ -0,0 +1,11 @@
+# special case skip regeneration
+
+qt_internal_add_qml_module(quickwindow
+ URI "QtQuick.Window"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ IMPORTS
+ QtQuick/auto
+ PAST_MAJOR_VERSIONS 2
+ GENERATE_QMLTYPES
+ INSTALL_QMLTYPES
+)