aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/CMakeLists.txt40
-rw-r--r--src/imports/builtins/.prev_CMakeLists.txt2
-rw-r--r--src/imports/builtins/CMakeLists.txt18
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt29
-rw-r--r--src/imports/labsanimation/CMakeLists.txt26
-rw-r--r--src/imports/labsmodels/CMakeLists.txt26
-rw-r--r--src/imports/layouts/CMakeLists.txt36
-rw-r--r--src/imports/localstorage/CMakeLists.txt28
-rw-r--r--src/imports/models/CMakeLists.txt28
-rw-r--r--src/imports/particles/CMakeLists.txt31
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt30
-rw-r--r--src/imports/qtqml/CMakeLists.txt31
-rw-r--r--src/imports/qtquick2/CMakeLists.txt44
-rw-r--r--src/imports/settings/CMakeLists.txt24
-rw-r--r--src/imports/shapes/CMakeLists.txt30
-rw-r--r--src/imports/sharedimage/CMakeLists.txt31
-rw-r--r--src/imports/statemachine/CMakeLists.txt32
-rw-r--r--src/imports/testlib/.prev_CMakeLists.txt51
-rw-r--r--src/imports/testlib/CMakeLists.txt56
-rw-r--r--src/imports/testlib/qmldir1
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt29
-rw-r--r--src/imports/window/CMakeLists.txt30
-rw-r--r--src/imports/workerscript/CMakeLists.txt28
23 files changed, 680 insertions, 1 deletions
diff --git a/src/imports/CMakeLists.txt b/src/imports/CMakeLists.txt
new file mode 100644
index 0000000000..1399ad533a
--- /dev/null
+++ b/src/imports/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Generated from imports.pro.
+
+add_subdirectory(builtins)
+add_subdirectory(qtqml)
+add_subdirectory(models)
+add_subdirectory(labsmodels)
+if(QT_FEATURE_qml_itemmodel)
+ add_subdirectory(folderlistmodel)
+endif()
+if(QT_FEATURE_qml_worker_script)
+ add_subdirectory(workerscript)
+endif()
+if(TARGET Qt::Sql)
+ add_subdirectory(localstorage)
+endif()
+if(QT_FEATURE_settings)
+ add_subdirectory(settings)
+endif()
+if(QT_FEATURE_statemachine)
+ add_subdirectory(statemachine)
+endif()
+if(TARGET Qt::Quick)
+ add_subdirectory(labsanimation)
+ add_subdirectory(layouts)
+ add_subdirectory(qtquick2)
+ add_subdirectory(window)
+ add_subdirectory(wavefrontmesh)
+endif()
+if(TARGET Qt::Quick AND TARGET Qt::Test)
+ add_subdirectory(testlib)
+endif()
+if(QT_FEATURE_systemsemaphore AND TARGET Qt::Quick)
+ add_subdirectory(sharedimage)
+endif()
+if(QT_FEATURE_quick_particles AND TARGET Qt::Quick)
+ add_subdirectory(particles)
+endif()
+if(QT_FEATURE_quick_path AND QT_FEATURE_thread AND TARGET Qt::Quick)
+ add_subdirectory(shapes)
+endif()
diff --git a/src/imports/builtins/.prev_CMakeLists.txt b/src/imports/builtins/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..088b0b73f0
--- /dev/null
+++ b/src/imports/builtins/.prev_CMakeLists.txt
@@ -0,0 +1,2 @@
+# Generated from builtins.pro.
+
diff --git a/src/imports/builtins/CMakeLists.txt b/src/imports/builtins/CMakeLists.txt
new file mode 100644
index 0000000000..93057d6605
--- /dev/null
+++ b/src/imports/builtins/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Generated from builtins.pro.
+
+# special case begin
+
+set(qml_type_file builtins.qmltypes)
+
+qt_copy_or_install(FILES ${qml_type_file}
+ DESTINATION ${INSTALL_QMLDIR}
+)
+
+if (NOT CMAKE_CROSSCOMPILING)
+
+ add_custom_target(builtins_qmltypes
+ COMMAND qmlplugindump -builtins > ${CMAKE_CURRENT_SOURCE_DIR}/${qml_type_file}
+ )
+endif()
+
+# special case end
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
new file mode 100644
index 0000000000..d9bb57c950
--- /dev/null
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from folderlistmodel.pro.
+
+#####################################################################
+## qmlfolderlistmodelplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlfolderlistmodelplugin
+ URI "Qt.labs.folderlistmodel"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QmlFolderListModelPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ fileinfothread.cpp fileinfothread_p.h
+ fileproperty_p.h
+ plugin.cpp
+ qquickfolderlistmodel.cpp qquickfolderlistmodel.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:folderlistmodel.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "Qt/labs/folderlistmodel"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
new file mode 100644
index 0000000000..e0b322552e
--- /dev/null
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from labsanimation.pro.
+
+#####################################################################
+## labsanimationplugin Plugin:
+#####################################################################
+
+add_qml_module(labsanimationplugin
+ URI "Qt.labs.animation"
+ VERSION "1.0"
+ CLASSNAME QtLabsAnimationPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:labsanimation.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.0"
+# TARGETPATH = "Qt/labs/animation"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
new file mode 100644
index 0000000000..268120ffc1
--- /dev/null
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from labsmodels.pro.
+
+#####################################################################
+## labsmodelsplugin Plugin:
+#####################################################################
+
+add_qml_module(labsmodelsplugin
+ URI "Qt.labs.qmlmodels"
+ VERSION "1.0"
+ CLASSNAME QtQmlLabsModelsPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlModels
+)
+
+#### Keys ignored in scope 1:.:.:labsmodels.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.0"
+# TARGETPATH = "Qt/labs/qmlmodels"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
new file mode 100644
index 0000000000..dbfefb239d
--- /dev/null
+++ b/src/imports/layouts/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from layouts.pro.
+
+#####################################################################
+## qquicklayoutsplugin Plugin:
+#####################################################################
+
+add_qml_module(qquicklayoutsplugin
+ URI "QtQuick.Layouts"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuickLayoutsPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ qquickgridlayoutengine.cpp qquickgridlayoutengine_p.h
+ qquicklayout.cpp qquicklayout_p.h
+ qquicklayoutstyleinfo.cpp qquicklayoutstyleinfo_p.h
+ qquicklinearlayout.cpp qquicklinearlayout_p.h
+ qquickstacklayout.cpp qquickstacklayout_p.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:layouts.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQuick/Layouts"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
new file mode 100644
index 0000000000..22ee1b947b
--- /dev/null
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from localstorage.pro.
+
+#####################################################################
+## qmllocalstorageplugin Plugin:
+#####################################################################
+
+add_qml_module(qmllocalstorageplugin
+ URI "QtQuick.LocalStorage"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QQmlLocalStoragePlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::Sql
+)
+
+#### Keys ignored in scope 1:.:.:localstorage.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "localstorage.json"
+# TARGETPATH = "QtQuick/LocalStorage"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
new file mode 100644
index 0000000000..a7affed6e4
--- /dev/null
+++ b/src/imports/models/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from models.pro.
+
+#####################################################################
+## modelsplugin Plugin:
+#####################################################################
+
+add_qml_module(modelsplugin
+ TARGET_PATH "QtQml/Models.2"
+ URI "QtQml.Models"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlModelsPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlModels
+)
+
+#### Keys ignored in scope 1:.:.:models.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml/Models.2"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
new file mode 100644
index 0000000000..04fd522837
--- /dev/null
+++ b/src/imports/particles/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from particles.pro.
+
+#####################################################################
+## particlesplugin Plugin:
+#####################################################################
+
+add_qml_module(particlesplugin
+ TARGET_PATH "QtQuick/Particles.2"
+ URI "QtQuick.Particles"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuick2ParticlesPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlPrivate
+ Qt::QuickParticlesPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickParticles
+)
+
+#### Keys ignored in scope 1:.:.:particles.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQuick/Particles.2"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..e8261aa5c7
--- /dev/null
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from qtqml.pro.
+
+#####################################################################
+## qmlplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlplugin
+ URI "QtQml"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ IMPORTS
+ QtQml.Models
+ QtQml.WorkerScript
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlModels
+)
+
+#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
new file mode 100644
index 0000000000..185116e6ce
--- /dev/null
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from qtqml.pro.
+
+#####################################################################
+## qmlplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlplugin
+ URI "QtQml"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ IMPORTS
+ QtQml.Models
+ QtQml.WorkerScript
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ Qt::CorePrivate # special case
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlModels
+)
+
+#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/qtquick2/CMakeLists.txt b/src/imports/qtquick2/CMakeLists.txt
new file mode 100644
index 0000000000..f40864b8e0
--- /dev/null
+++ b/src/imports/qtquick2/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from qtquick2.pro.
+
+#####################################################################
+## qtquick2plugin Plugin:
+#####################################################################
+
+add_qml_module(qtquick2plugin
+ TARGET_PATH "QtQuick.2"
+ URI "QtQuick"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuick2Plugin
+ IMPORTS
+ QtQml
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::QmlModels
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:qtquick2.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQuick.2"
+# _LOADED = "qml_plugin"
+
+## Scopes:
+#####################################################################
+
+extend_target(qtquick2plugin CONDITION QT_FEATURE_qml_worker_script
+ LIBRARIES
+ Qt::QmlWorkerScriptPrivate
+ PUBLIC_LIBRARIES
+ Qt::QmlWorkerScript
+)
diff --git a/src/imports/settings/CMakeLists.txt b/src/imports/settings/CMakeLists.txt
new file mode 100644
index 0000000000..57ab9efa89
--- /dev/null
+++ b/src/imports/settings/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from settings.pro.
+
+#####################################################################
+## qmlsettingsplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlsettingsplugin
+ URI "Qt.labs.settings"
+ VERSION "1.1"
+ CLASSNAME QmlSettingsPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ qqmlsettings.cpp qqmlsettings_p.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:settings.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.1"
+# TARGETPATH = "Qt/labs/settings"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
new file mode 100644
index 0000000000..c91c246ace
--- /dev/null
+++ b/src/imports/shapes/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from shapes.pro.
+
+#####################################################################
+## qmlshapesplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlshapesplugin
+ URI "QtQuick.Shapes"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QmlShapesPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ Qt::QuickPrivate
+ Qt::QuickShapesPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickShapes
+)
+
+#### Keys ignored in scope 1:.:.:shapes.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQuick/Shapes"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
new file mode 100644
index 0000000000..6dbf8f8ab7
--- /dev/null
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from sharedimage.pro.
+
+#####################################################################
+## sharedimageplugin Plugin:
+#####################################################################
+
+add_qml_module(sharedimageplugin
+ URI "Qt.labs.sharedimage"
+ VERSION "1.0"
+ CLASSNAME QtQuickSharedImagePlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ qsharedimageloader.cpp qsharedimageloader_p.h
+ sharedimageprovider.cpp sharedimageprovider.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:sharedimage.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.0"
+# TARGETPATH = "Qt/labs/sharedimage"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/statemachine/CMakeLists.txt b/src/imports/statemachine/CMakeLists.txt
new file mode 100644
index 0000000000..f06fed1765
--- /dev/null
+++ b/src/imports/statemachine/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Generated from statemachine.pro.
+
+#####################################################################
+## qtqmlstatemachine Plugin:
+#####################################################################
+
+add_qml_module(qtqmlstatemachine
+ URI "QtQml.StateMachine"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQmlStateMachinePlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ childrenprivate.h
+ finalstate.cpp finalstate.h
+ plugin.cpp
+ signaltransition.cpp signaltransition.h
+ state.cpp state.h
+ statemachine.cpp statemachine.h
+ timeouttransition.cpp timeouttransition.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:statemachine.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml/StateMachine"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/testlib/.prev_CMakeLists.txt b/src/imports/testlib/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..17cfcc34ec
--- /dev/null
+++ b/src/imports/testlib/.prev_CMakeLists.txt
@@ -0,0 +1,51 @@
+# Generated from testlib.pro.
+
+#####################################################################
+## qmltestplugin Plugin:
+#####################################################################
+
+add_qml_module(qmltestplugin
+ URI "QtTest"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::QuickTestPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickTest
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# TARGETPATH = "QtTest"
+# _LOADED = "qml_plugin"
+
+set(qml_files
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+
+qt6_target_qml_files(qmltestplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
new file mode 100644
index 0000000000..b72e907fcb
--- /dev/null
+++ b/src/imports/testlib/CMakeLists.txt
@@ -0,0 +1,56 @@
+# Generated from testlib.pro.
+
+#####################################################################
+## qmltestplugin Plugin:
+#####################################################################
+
+add_qml_module(qmltestplugin
+ URI "QtTest"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::QuickTestPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickTest
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# TARGETPATH = "QtTest"
+# _LOADED = "qml_plugin"
+
+set(qml_files
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+# special case begin
+set_source_files_properties(testlogger.js PROPERTIES
+ QT_QML_SOURCE_INSTALL TRUE
+)
+# special case end
+
+qt6_target_qml_files(qmltestplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/testlib/qmldir b/src/imports/testlib/qmldir
index be9039abbb..9c1e8dd61f 100644
--- a/src/imports/testlib/qmldir
+++ b/src/imports/testlib/qmldir
@@ -3,6 +3,5 @@ plugin qmltestplugin
classname QTestQmlModule
typeinfo plugins.qmltypes
TestCase 1.0 TestCase.qml
-TestCase 1.2 TestCase.qml
SignalSpy 1.0 SignalSpy.qml
depends QtQuick.Window 2.0
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
new file mode 100644
index 0000000000..41a88305c7
--- /dev/null
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from wavefrontmesh.pro.
+
+#####################################################################
+## qmlwavefrontmeshplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlwavefrontmeshplugin
+ URI "Qt.labs.wavefrontmesh"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QmlWavefrontMeshPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ qwavefrontmesh.cpp qwavefrontmesh.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:wavefrontmesh.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# TARGETPATH = "Qt/labs/wavefrontmesh"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/window/CMakeLists.txt b/src/imports/window/CMakeLists.txt
new file mode 100644
index 0000000000..9301f86038
--- /dev/null
+++ b/src/imports/window/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from window.pro.
+
+#####################################################################
+## windowplugin Plugin:
+#####################################################################
+
+add_qml_module(windowplugin
+ TARGET_PATH "QtQuick/Window.2"
+ URI "QtQuick.Window"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuick2WindowPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:window.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQuick/Window.2"
+# _LOADED = "qml_plugin"
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
new file mode 100644
index 0000000000..ae0da6de0c
--- /dev/null
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from workerscript.pro.
+
+#####################################################################
+## workerscriptplugin Plugin:
+#####################################################################
+
+add_qml_module(workerscriptplugin
+ TARGET_PATH "QtQml/WorkerScript.2"
+ URI "QtQml.WorkerScript"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlWorkerScriptPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlPrivate
+ Qt::QmlWorkerScriptPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlWorkerScript
+)
+
+#### Keys ignored in scope 1:.:.:workerscript.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQml/WorkerScript.2"
+# _LOADED = "qml_plugin"