aboutsummaryrefslogtreecommitdiffstats
path: root/src/labs/folderlistmodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/labs/folderlistmodel/CMakeLists.txt')
-rw-r--r--src/labs/folderlistmodel/CMakeLists.txt33
1 files changed, 16 insertions, 17 deletions
diff --git a/src/labs/folderlistmodel/CMakeLists.txt b/src/labs/folderlistmodel/CMakeLists.txt
index 7f087a0a6e..bcb7b7d94f 100644
--- a/src/labs/folderlistmodel/CMakeLists.txt
+++ b/src/labs/folderlistmodel/CMakeLists.txt
@@ -1,24 +1,23 @@
-qt_internal_add_module(LabsFolderListModel
- GENERATE_METATYPES
- SOURCES
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(LabsFolderListModel
+ URI "Qt.labs.folderlistmodel"
+ VERSION "${PROJECT_VERSION}"
+ DEPENDENCIES
+ QtQml.Models/auto
+ PLUGIN_TARGET qmlfolderlistmodelplugin
+ CLASS_NAME QmlFolderListModelPlugin
+ SOURCES
fileinfothread.cpp fileinfothread_p.h
fileproperty_p.h
qquickfolderlistmodel.cpp qquickfolderlistmodel_p.h
qquickfolderlistmodelglobal_p.h
- DEFINES
+ DEFINES
QT_BUILD_LABSFOLDERMODEL_LIB
- PUBLIC_LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
-)
-
-set_target_properties(LabsFolderListModel PROPERTIES
- QT_QML_MODULE_INSTALL_QMLTYPES TRUE
- QT_QML_MODULE_VERSION ${CMAKE_PROJECT_VERSION}
- QT_QML_MODULE_URI Qt.labs.folderlistmodel
- QT_QMLTYPES_FILENAME plugins.qmltypes
- QT_QML_MODULE_INSTALL_DIR "${INSTALL_QMLDIR}/Qt/labs/folderlistmodel"
-)
-
-
-qt6_qml_type_registration(LabsFolderListModel)
+ Qt::QmlModelsPrivate
+ GENERATE_CPP_EXPORTS
+ )