aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmltooling/qmldbg_nativedebugger/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/qmltooling/qmldbg_nativedebugger/CMakeLists.txt')
-rw-r--r--src/plugins/qmltooling/qmldbg_nativedebugger/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/plugins/qmltooling/qmldbg_nativedebugger/CMakeLists.txt b/src/plugins/qmltooling/qmldbg_nativedebugger/CMakeLists.txt
new file mode 100644
index 0000000000..348f2b9386
--- /dev/null
+++ b/src/plugins/qmltooling/qmldbg_nativedebugger/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from qmldbg_nativedebugger.pro.
+
+#####################################################################
+## qmldbg_nativedebugger Plugin:
+#####################################################################
+
+add_qt_plugin(qmldbg_nativedebugger
+ TYPE qmltooling
+ CLASS_NAME QQmlNativeDebugServiceFactory
+ SOURCES
+ qqmlnativedebugservice.cpp qqmlnativedebugservice.h
+ qqmlnativedebugservicefactory.cpp qqmlnativedebugservicefactory.h
+ LIBRARIES
+ Qt::PacketProtocolPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::PacketProtocol
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:qmldbg_nativedebugger.pro:<TRUE>:
+# OTHER_FILES = "$$PWD/qqmlnativedebugservice.json"
+# PLUGIN_CLASS_NAME = "QQmlNativeDebugServiceFactory"
+# PLUGIN_TYPE = "qmltooling"
+# _LOADED = "qt_plugin"