aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmlcompiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/qmlcompiler/CMakeLists.txt')
-rw-r--r--src/qmlcompiler/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/qmlcompiler/CMakeLists.txt b/src/qmlcompiler/CMakeLists.txt
new file mode 100644
index 0000000000..d6895704a4
--- /dev/null
+++ b/src/qmlcompiler/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from qmlcompiler.pro.
+
+#####################################################################
+## QmlCompiler Module:
+#####################################################################
+
+qt_add_module(QmlCompiler
+ STATIC
+ INTERNAL_MODULE
+ SOURCES
+ importedmembersvisitor.cpp importedmembersvisitor_p.h
+ metatypes_p.h
+ qmljsimporter.cpp qmljsimporter_p.h
+ qmljstypereader.cpp qmljstypereader_p.h
+ qmlstreamwriter.cpp qmlstreamwriter_p.h
+ resourcefilemapper.cpp resourcefilemapper_p.h
+ scopetree.cpp scopetree_p.h
+ typedescriptionreader.cpp typedescriptionreader_p.h
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlDevToolsPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qmlcompiler.pro:<TRUE>:
+# _OPTION = "host_build"