aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmllocalstorage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/qmllocalstorage/CMakeLists.txt')
-rw-r--r--src/qmllocalstorage/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/qmllocalstorage/CMakeLists.txt b/src/qmllocalstorage/CMakeLists.txt
new file mode 100644
index 0000000000..7c6846dce1
--- /dev/null
+++ b/src/qmllocalstorage/CMakeLists.txt
@@ -0,0 +1,23 @@
+qt_internal_add_module(QmlLocalStorage
+ GENERATE_METATYPES
+ SOURCES
+ qqmllocalstorage.cpp qqmllocalstorage_p.h
+ qqmllocalstorageglobal_p.h
+ DEFINES
+ QT_BUILD_QMLLOCALSTORAGE_LIB
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::Sql
+)
+
+set_target_properties(QmlLocalStorage PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION ${CMAKE_PROJECT_VERSION}
+ QT_QML_MODULE_URI QtQuick.LocalStorage
+ QT_QMLTYPES_FILENAME plugins.qmltypes
+ QT_QML_MODULE_INSTALL_DIR "${INSTALL_QMLDIR}/QtQuick/LocalStorage"
+)
+
+
+qt6_qml_type_registration(QmlLocalStorage)