aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/empty_qmldir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/empty_qmldir/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/empty_qmldir/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/auto/cmake/empty_qmldir/CMakeLists.txt b/tests/auto/cmake/empty_qmldir/CMakeLists.txt
index 432e6e99da..259adc2610 100644
--- a/tests/auto/cmake/empty_qmldir/CMakeLists.txt
+++ b/tests/auto/cmake/empty_qmldir/CMakeLists.txt
@@ -14,6 +14,11 @@ endif()
qt_add_executable(empty_qmldir_test main.cpp)
target_link_libraries(empty_qmldir_test PRIVATE Qt6::Test)
+if(ANDROID)
+ # Tests link to Gui by default beacuse it's needed for Android (QTBUG-83997) when
+ # using qt_internal_add_test() but not here where qt_add_executable() is used.
+ target_link_libraries(empty_qmldir_test PRIVATE Qt6::Gui)
+endif()
qt_add_qml_module(empty_qmldir_test
URI Third