aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/qtquickcompiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/qtquickcompiler/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/qtquickcompiler/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/auto/cmake/qtquickcompiler/CMakeLists.txt b/tests/auto/cmake/qtquickcompiler/CMakeLists.txt
index 6dee1e25dc..4e46544767 100644
--- a/tests/auto/cmake/qtquickcompiler/CMakeLists.txt
+++ b/tests/auto/cmake/qtquickcompiler/CMakeLists.txt
@@ -4,11 +4,14 @@ project(qqc_test)
find_package(Qt5Qml 5.0.0 REQUIRED)
find_package(Qt5Gui 5.0.0 REQUIRED)
+find_package(Qt5Test 5.0.0 REQUIRED)
find_package(Qt5QuickCompiler)
set(CMAKE_CXXFLAGS "${CMAKE_CXXFLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-qtquick_compiler_add_resources(RESOURCES qqc_test.qrc)
+qtquick_compiler_add_resources(RESOURCES "resources with space/qqc_test.qrc")
+
+set(CMAKE_AUTOMOC ON)
add_executable(qqc_test "${CMAKE_CURRENT_SOURCE_DIR}/main.cpp" ${RESOURCES})
-target_link_libraries(qqc_test Qt5::Gui Qt5::Qml)
+target_link_libraries(qqc_test Qt5::Gui Qt5::Qml Qt5::Test)