aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_plugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_plugins/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_plugins/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_plugins/CMakeLists.txt b/tests/auto/cmake/test_plugins/CMakeLists.txt
new file mode 100644
index 0000000000..a23f9c332c
--- /dev/null
+++ b/tests/auto/cmake/test_plugins/CMakeLists.txt
@@ -0,0 +1,16 @@
+project(test_plugins)
+
+cmake_minimum_required(VERSION 2.8)
+if (POLICY CMP0056)
+ cmake_policy(SET CMP0056 NEW)
+endif()
+
+find_package(Qt5Qml REQUIRED)
+
+# See QTBUG-43438
+if (NOT TARGET Qt5::QTcpServerConnectionFactory)
+ message(SEND_ERROR "Qt5::QTcpServerConnectionFactory does not exist")
+endif()
+if (NOT TARGET Qt5::QLocalClientConnectionFactory)
+ message(SEND_ERROR "Qt5::QLocalClientConnectionFactory does not exist")
+endif()