aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/debugger/qpacketprotocol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/debugger/qpacketprotocol/CMakeLists.txt')
-rw-r--r--tests/auto/qml/debugger/qpacketprotocol/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/tests/auto/qml/debugger/qpacketprotocol/CMakeLists.txt b/tests/auto/qml/debugger/qpacketprotocol/CMakeLists.txt
new file mode 100644
index 0000000000..08f8ae3694
--- /dev/null
+++ b/tests/auto/qml/debugger/qpacketprotocol/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from qpacketprotocol.pro.
+
+#####################################################################
+## tst_qpacketprotocol Test:
+#####################################################################
+
+add_qt_test(tst_qpacketprotocol
+ GUI
+ SOURCES
+ ../../../shared/util.cpp ../../../shared/util.h
+ ../shared/debugutil.cpp ../shared/debugutil_p.h
+ ../shared/qqmldebugprocess.cpp ../shared/qqmldebugprocess_p.h
+ tst_qpacketprotocol.cpp
+ INCLUDE_DIRECTORIES
+ ../../../shared
+ ../shared
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlDebugPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Network
+ Qt::QmlDebug
+)
+
+#### Keys ignored in scope 1:.:.:qpacketprotocol.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qpacketprotocol.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"
+
+extend_target(tst_qpacketprotocol CONDITION ANDROID OR APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\":/data\\\"
+)
+
+extend_target(tst_qpacketprotocol CONDITION NOT ANDROID AND NOT APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+)