aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/debugger/qqmldebuggingenabler/qqmldebuggingenabler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/debugger/qqmldebuggingenabler/qqmldebuggingenabler/CMakeLists.txt')
-rw-r--r--tests/auto/qml/debugger/qqmldebuggingenabler/qqmldebuggingenabler/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/auto/qml/debugger/qqmldebuggingenabler/qqmldebuggingenabler/CMakeLists.txt b/tests/auto/qml/debugger/qqmldebuggingenabler/qqmldebuggingenabler/CMakeLists.txt
new file mode 100644
index 0000000000..59a5aa9fa1
--- /dev/null
+++ b/tests/auto/qml/debugger/qqmldebuggingenabler/qqmldebuggingenabler/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Generated from qqmldebuggingenabler.pro.
+
+#####################################################################
+## tst_qqmldebuggingenabler Test:
+#####################################################################
+
+add_qt_test(tst_qqmldebuggingenabler
+ GUI
+ SOURCES
+ ../../../../shared/util.cpp ../../../../shared/util.h
+ ../../shared/debugutil.cpp ../../shared/debugutil_p.h
+ ../../shared/qqmldebugprocess.cpp ../../shared/qqmldebugprocess_p.h
+ tst_qqmldebuggingenabler.cpp
+ INCLUDE_DIRECTORIES
+ ../../../../shared
+ ../../shared
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlDebugPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::QmlDebug
+)
+
+#### Keys ignored in scope 1:.:.:qqmldebuggingenabler.pro:<TRUE>:
+# CONFIG = "testcase" "-debug_and_release_target"
+# OTHER_FILES = "data/test.qml"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qqmldebuggingenabler.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"
+
+extend_target(tst_qqmldebuggingenabler CONDITION ANDROID OR APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\":/data\\\"
+)
+
+extend_target(tst_qqmldebuggingenabler CONDITION NOT ANDROID AND NOT APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+)