aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/debugger/qqmlenginecontrol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/debugger/qqmlenginecontrol/CMakeLists.txt')
-rw-r--r--tests/auto/qml/debugger/qqmlenginecontrol/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/tests/auto/qml/debugger/qqmlenginecontrol/CMakeLists.txt b/tests/auto/qml/debugger/qqmlenginecontrol/CMakeLists.txt
index 6c2da84ce8..bf90555c47 100644
--- a/tests/auto/qml/debugger/qqmlenginecontrol/CMakeLists.txt
+++ b/tests/auto/qml/debugger/qqmlenginecontrol/CMakeLists.txt
@@ -5,15 +5,12 @@
#####################################################################
# Collect test data
-
-file(GLOB test_data_glob
- LIST_DIRECTORIES true
+file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "data/*")
+ data/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qqmlenginecontrol
- GUI
SOURCES
../../../shared/util.cpp ../../../shared/util.h
../shared/debugutil.cpp ../shared/debugutil_p.h
@@ -33,15 +30,11 @@ add_qt_test(tst_qqmlenginecontrol
)
#### Keys ignored in scope 1:.:.:qqmlenginecontrol.pro:<TRUE>:
-# CONFIG = "testcase"
# OTHER_FILES = "data/test.qml" "data/exit.qml"
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qqmlenginecontrol.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qqmlenginecontrol CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"