aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt')
-rw-r--r--tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt b/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt
new file mode 100644
index 0000000000..9235577d89
--- /dev/null
+++ b/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Generated from qqmlenginedebugservice.pro.
+
+#####################################################################
+## tst_qqmlenginedebugservice Test:
+#####################################################################
+
+add_qt_test(tst_qqmlenginedebugservice
+ GUI
+ SOURCES
+ ../../../shared/util.cpp ../../../shared/util.h
+ ../shared/debugutil.cpp ../shared/debugutil_p.h
+ ../shared/qqmldebugprocess.cpp ../shared/qqmldebugprocess_p.h
+ tst_qqmlenginedebugservice.cpp
+ DEFINES
+ QT_QML_DEBUG_NO_WARNING
+ INCLUDE_DIRECTORIES
+ ../../../shared
+ ../shared
+ LIBRARIES
+ Qt::QmlDebugPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::QmlDebug
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:qqmlenginedebugservice.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qqmlenginedebugservice.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"
+
+extend_target(tst_qqmlenginedebugservice CONDITION ANDROID OR APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\":/data\\\"
+)
+
+extend_target(tst_qqmlenginedebugservice CONDITION NOT ANDROID AND NOT APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+)