aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/ecmascripttests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/ecmascripttests/CMakeLists.txt')
-rw-r--r--tests/auto/qml/ecmascripttests/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/auto/qml/ecmascripttests/CMakeLists.txt b/tests/auto/qml/ecmascripttests/CMakeLists.txt
new file mode 100644
index 0000000000..00357fb36b
--- /dev/null
+++ b/tests/auto/qml/ecmascripttests/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from ecmascripttests.pro.
+
+#####################################################################
+## tst_ecmascripttests Test:
+#####################################################################
+
+add_qt_test(tst_ecmascripttests
+ GUI
+ SOURCES
+ qjstest/test262runner.cpp qjstest/test262runner.h
+ tst_ecmascripttests.cpp
+ DEFINES
+ SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}\\\"
+ LIBRARIES
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+)
+
+#### Keys ignored in scope 2:.:.:testcase.pro:<TRUE>:
+# CONFIG = "testcase"
+# QT_TOOL_ENV = "checkenv"
+# checkenv.name = "QTEST_FUNCTION_TIMEOUT"
+# checkenv.value = "500000"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 3:.:.:testcase.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"
+add_subdirectory(qjstest)