aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmlcompiler_manual/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmlcompiler_manual/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmlcompiler_manual/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/tests/auto/qml/qmlcompiler_manual/CMakeLists.txt b/tests/auto/qml/qmlcompiler_manual/CMakeLists.txt
index 0afe49e760..ebd207e94b 100644
--- a/tests/auto/qml/qmlcompiler_manual/CMakeLists.txt
+++ b/tests/auto/qml/qmlcompiler_manual/CMakeLists.txt
@@ -7,23 +7,21 @@ list(APPEND test_data ${test_data_glob})
qt_internal_add_test(tst_qmlcompiler_manual
SOURCES
../../shared/util.cpp ../../shared/util.h
+ testclasses.h
tst_qmlcompiler_manual.cpp
INCLUDE_DIRECTORIES
../../shared
LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
- TESTDATA ${test_data}
)
-## Scopes:
-#####################################################################
-
-qt_add_resources(tst_qmlcompiler_manual "qmlcompiler"
- PREFIX
- "/"
- FILES
- "data/signalHandlers.qml"
+qt6_add_qml_module(tst_qmlcompiler_manual
+ VERSION 1.0
+ URI "QmltcManualTests"
+ NO_CREATE_PLUGIN_TARGET
+ QML_FILES
+ ${test_data}
)
qt_internal_extend_target(tst_qmlcompiler_manual CONDITION ANDROID OR IOS