aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmldiskcache/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmldiskcache/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmldiskcache/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/tests/auto/qml/qmldiskcache/CMakeLists.txt b/tests/auto/qml/qmldiskcache/CMakeLists.txt
new file mode 100644
index 0000000000..096641cae9
--- /dev/null
+++ b/tests/auto/qml/qmldiskcache/CMakeLists.txt
@@ -0,0 +1,48 @@
+# Generated from qmldiskcache.pro.
+
+#####################################################################
+## tst_qmldiskcache Test:
+#####################################################################
+
+add_qt_test(tst_qmldiskcache
+ GUI
+ SOURCES
+ tst_qmldiskcache.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+)
+
+# special case begin
+# Disable quick compiler for this test
+set_source_files_properties(
+ importmodule.qml
+ module.mjs
+ test.qml
+ PROPERTIES
+ QT_SKIP_QUICKCOMPILER TRUE
+)
+# special case end
+
+# Resources:
+add_qt_resource(tst_qmldiskcache "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ importmodule.qml
+ module.mjs
+ test.qml
+)
+
+
+#### Keys ignored in scope 1:.:.:qmldiskcache.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qmldiskcache.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"