aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmlmin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmlmin/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmlmin/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/auto/qml/qmlmin/CMakeLists.txt b/tests/auto/qml/qmlmin/CMakeLists.txt
new file mode 100644
index 0000000000..a14c76d14e
--- /dev/null
+++ b/tests/auto/qml/qmlmin/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from qmlmin.pro.
+
+#####################################################################
+## tst_qmlmin Test:
+#####################################################################
+
+add_qt_test(tst_qmlmin
+ SOURCES
+ tst_qmlmin.cpp
+ DEFINES
+ SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/.\\\"
+ LIBRARIES
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:qmlmin.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qmlmin.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"
+
+extend_target(tst_qmlmin CONDITION cross_compile AND NOT boot2qt
+ DEFINES
+ QTEST_CROSS_COMPILED
+)