aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlapplicationengine/testapp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlapplicationengine/testapp/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlapplicationengine/testapp/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlapplicationengine/testapp/CMakeLists.txt b/tests/auto/qml/qqmlapplicationengine/testapp/CMakeLists.txt
new file mode 100644
index 0000000000..6adbba2b49
--- /dev/null
+++ b/tests/auto/qml/qqmlapplicationengine/testapp/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from testapp.pro.
+
+#####################################################################
+## testapp Binary:
+#####################################################################
+
+add_qt_executable(testapp
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/./"
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+)
+
+# Resources:
+add_qt_resource(testapp "main"
+ PREFIX
+ "/"
+ FILES
+ delayedExit.qml
+ delayedQuit.qml
+ immediateExit.qml
+ immediateQuit.qml
+)
+
+
+#### Keys ignored in scope 1:.:.:testapp.pro:<TRUE>:
+# CONFIG = "-app_bundle" "console"
+# TEMPLATE = "app"