aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlenginecleanup/CustomModuleImport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlenginecleanup/CustomModuleImport/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlenginecleanup/CustomModuleImport/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlenginecleanup/CustomModuleImport/CMakeLists.txt b/tests/auto/qml/qqmlenginecleanup/CustomModuleImport/CMakeLists.txt
new file mode 100644
index 0000000000..5338e58334
--- /dev/null
+++ b/tests/auto/qml/qqmlenginecleanup/CustomModuleImport/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from CustomModule.pro.
+
+#####################################################################
+## stomModule Module:
+#####################################################################
+
+add_qt_plugin(CustomModule
+ # special case begin
+ TYPE qml_plugin
+ # special case end
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../CustomModule"
+ SOURCES
+ moduleplugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+add_qt_resource(CustomModule "moduleplugin"
+ PREFIX
+ "/"
+ FILES
+ ModuleType.qml
+)
+
+
+#### Keys ignored in scope 1:.:.:CustomModule.pro:<TRUE>:
+# CONFIG = "qtquickcompiler"
+# IMPORT_FILES = "qmldir"
+# TEMPLATE = "lib"
+
+# special case begin
+file(COPY qmldir
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/../CustomModule"
+)
+# special case end