aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlmoduleplugin/plugin.2.1/childplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlmoduleplugin/plugin.2.1/childplugin/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlmoduleplugin/plugin.2.1/childplugin/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlmoduleplugin/plugin.2.1/childplugin/CMakeLists.txt b/tests/auto/qml/qqmlmoduleplugin/plugin.2.1/childplugin/CMakeLists.txt
new file mode 100644
index 0000000000..b4362aaaf9
--- /dev/null
+++ b/tests/auto/qml/qqmlmoduleplugin/plugin.2.1/childplugin/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from childplugin.pro.
+
+#####################################################################
+## ildplugin Module:
+#####################################################################
+
+add_qt_plugin(childplugin.2.1
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../../imports/org/qtproject/AutoTestQmlPluginType.2.1/ChildPlugin"
+# special case begin
+ TYPE qml_plugin
+# special case end
+ SOURCES
+ childplugin.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:childplugin.pro:<TRUE>:
+# CONFIG = "childplugin"
+# IMPORT_FILES = "qmldir"
+# TEMPLATE = "lib"
+
+# special case begin
+set_target_properties(childplugin.2.1 PROPERTIES OUTPUT_NAME "childplugin")
+file(COPY qmldir
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/../../imports/org/qtproject/AutoTestQmlPluginType.2.1/ChildPlugin"
+)
+# special case end