aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlmoduleplugin/plugin.2.2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlmoduleplugin/plugin.2.2/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlmoduleplugin/plugin.2.2/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlmoduleplugin/plugin.2.2/CMakeLists.txt b/tests/auto/qml/qqmlmoduleplugin/plugin.2.2/CMakeLists.txt
new file mode 100644
index 0000000000..e2b36e8f09
--- /dev/null
+++ b/tests/auto/qml/qqmlmoduleplugin/plugin.2.2/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from plugin.2.2.pro.
+
+#####################################################################
+## plugin.2.2 Generic Library:
+#####################################################################
+
+qt_add_cmake_library(plugin.2.2
+ MODULE
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../imports/org/qtproject/AutoTestQmlPluginType.2.2"
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::Qml
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:plugin.2.2.pro:<TRUE>:
+# IMPORT_FILES = "qmldir"
+# TEMPLATE = "lib"
+
+qt_autogen_tools_initial_setup(plugin.2.2)
+# special case begin
+set_target_properties(plugin.2.2 PROPERTIES OUTPUT_NAME "plugin")
+file(COPY qmldir
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/../imports/org/qtproject/AutoTestQmlPluginType.2.2"
+)
+# special case end