aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt b/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt
new file mode 100644
index 0000000000..6a36a6190f
--- /dev/null
+++ b/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Generated from childplugin.pro.
+
+#####################################################################
+## ildplugin Module:
+#####################################################################
+
+add_qt_plugin(childplugin.2
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../../imports/org/qtproject/AutoTestQmlPluginType.2/ChildPlugin"
+# special case begin
+ TYPE qml_plugin
+# special case end
+ SOURCES
+ childplugin.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:childplugin.pro:<TRUE>:
+# CONFIG = "childplugin"
+# IMPORT_DIR = "DESTDIR"
+# IMPORT_FILES = "qmldir"
+# TEMPLATE = "lib"
+
+# special case begin
+set_target_properties(childplugin.2 PROPERTIES OUTPUT_NAME "childplugin")
+file(COPY qmldir
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/../../imports/org/qtproject/AutoTestQmlPluginType.2/ChildPlugin"
+)
+# special case end