aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlmoduleplugin/strictModule.2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlmoduleplugin/strictModule.2/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlmoduleplugin/strictModule.2/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlmoduleplugin/strictModule.2/CMakeLists.txt b/tests/auto/qml/qqmlmoduleplugin/strictModule.2/CMakeLists.txt
new file mode 100644
index 0000000000..5b76d771fa
--- /dev/null
+++ b/tests/auto/qml/qqmlmoduleplugin/strictModule.2/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from strictModule.2.pro.
+
+#####################################################################
+## strictModule.2 Plugin:
+#####################################################################
+
+add_qt_plugin(strictModule.2
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../imports/org/qtproject/StrictModule.2"
+# special case begin
+ TYPE qml_plugin
+# special case end
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:strictModule.2.pro:<TRUE>:
+# CONFIG = "plugin"
+# IMPORT_FILES = "qmldir"
+# TEMPLATE = "lib"
+
+# special case begin
+set_target_properties(strictModule.2 PROPERTIES OUTPUT_NAME "strictModule")
+file(COPY qmldir
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/../imports/org/qtproject/StrictModule.2"
+)
+# special case end