aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlmoduleplugin/strictModule/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlmoduleplugin/strictModule/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlmoduleplugin/strictModule/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlmoduleplugin/strictModule/CMakeLists.txt b/tests/auto/qml/qqmlmoduleplugin/strictModule/CMakeLists.txt
new file mode 100644
index 0000000000..98508d32bf
--- /dev/null
+++ b/tests/auto/qml/qqmlmoduleplugin/strictModule/CMakeLists.txt
@@ -0,0 +1,33 @@
+# Generated from strictModule.pro.
+
+#####################################################################
+## strictModule Plugin:
+#####################################################################
+
+add_qt_plugin(strictModule
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../imports/org/qtproject/StrictModule"
+# special case begin
+ TYPE qml_plugin
+# special case end
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:strictModule.pro:<TRUE>:
+# CONFIG = "plugin"
+# IMPORT_FILES = "qmldir"
+# TEMPLATE = "lib"
+
+# special case begin
+file(COPY qmldir
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/../imports/org/qtproject/StrictModule"
+)
+# special case end