aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlproperty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlproperty/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlproperty/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/tests/auto/qml/qqmlproperty/CMakeLists.txt b/tests/auto/qml/qqmlproperty/CMakeLists.txt
index 6ef1e1fbba..f34d6c372f 100644
--- a/tests/auto/qml/qqmlproperty/CMakeLists.txt
+++ b/tests/auto/qml/qqmlproperty/CMakeLists.txt
@@ -5,15 +5,12 @@
#####################################################################
# Collect test data
-
-file(GLOB test_data_glob
- LIST_DIRECTORIES true
+file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "data/*")
+ data/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qqmlproperty
- GUI
SOURCES
../../shared/util.cpp ../../shared/util.h
tst_qqmlproperty.cpp
@@ -29,15 +26,9 @@ add_qt_test(tst_qqmlproperty
TESTDATA ${test_data}
)
-#### Keys ignored in scope 1:.:.:qqmlproperty.pro:<TRUE>:
-# CONFIG = "testcase"
-
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qqmlproperty.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qqmlproperty CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"