aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlproperty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlproperty/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlproperty/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlproperty/CMakeLists.txt b/tests/auto/qml/qqmlproperty/CMakeLists.txt
index dbe648bd2f..5899210558 100644
--- a/tests/auto/qml/qqmlproperty/CMakeLists.txt
+++ b/tests/auto/qml/qqmlproperty/CMakeLists.txt
@@ -13,6 +13,7 @@ list(APPEND test_data ${test_data_glob})
qt_add_test(tst_qqmlproperty
SOURCES
../../shared/util.cpp ../../shared/util.h
+ interfaces.h
tst_qqmlproperty.cpp
INCLUDE_DIRECTORIES
../../shared
@@ -24,6 +25,10 @@ qt_add_test(tst_qqmlproperty
TESTDATA ${test_data}
)
+#### Keys ignored in scope 1:.:.:qqmlproperty.pro:<TRUE>:
+# QML_IMPORT_NAME = "io.qt.bugreports"
+# QML_IMPORT_VERSION = "2.0"
+
## Scopes:
#####################################################################
@@ -36,3 +41,11 @@ qt_extend_target(tst_qqmlproperty CONDITION NOT ANDROID AND NOT APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
)
+
+set_target_properties(tst_qqmlproperty PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 2.0
+ QT_QML_MODULE_URI io.qt.bugreports
+)
+
+qt6_qml_type_registration(tst_qqmlproperty)