aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlstatemachine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlstatemachine/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlstatemachine/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlstatemachine/CMakeLists.txt b/tests/auto/qml/qqmlstatemachine/CMakeLists.txt
new file mode 100644
index 0000000000..e187fe7b1f
--- /dev/null
+++ b/tests/auto/qml/qqmlstatemachine/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from qqmlstatemachine.pro.
+
+#####################################################################
+## tst_qqmlstatemachine Test:
+#####################################################################
+
+add_qt_test(tst_qqmlstatemachine
+ GUI
+ SOURCES
+ ../../shared/util.cpp ../../shared/util.h
+ tst_qqmlstatemachine.cpp
+ INCLUDE_DIRECTORIES
+ ../../shared
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:qqmlstatemachine.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qqmlstatemachine.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"
+
+extend_target(tst_qqmlstatemachine CONDITION ANDROID OR APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\":/data\\\"
+)
+
+extend_target(tst_qqmlstatemachine CONDITION NOT ANDROID AND NOT APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+)