aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/CMakeLists.txt')
-rw-r--r--tests/auto/quick/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/auto/quick/CMakeLists.txt b/tests/auto/quick/CMakeLists.txt
index de701f909d..0eed29a685 100644
--- a/tests/auto/quick/CMakeLists.txt
+++ b/tests/auto/quick/CMakeLists.txt
@@ -2,9 +2,14 @@
add_subdirectory(geometry)
add_subdirectory(nodes)
-add_subdirectory(drawingmodes)
add_subdirectory(qquickpixmapcache)
+# Limit set of tests to run for static Qt builds.
+if(QT_BUILD_MINIMAL_STATIC_TESTS)
+ return()
+endif()
+add_subdirectory(drawingmodes)
+
if(QT_FEATURE_private_tests)
add_subdirectory(examples)
add_subdirectory(nokeywords)