aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/pointerhandlers/qquickpointerhandler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/pointerhandlers/qquickpointerhandler/CMakeLists.txt')
-rw-r--r--tests/auto/quick/pointerhandlers/qquickpointerhandler/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/tests/auto/quick/pointerhandlers/qquickpointerhandler/CMakeLists.txt b/tests/auto/quick/pointerhandlers/qquickpointerhandler/CMakeLists.txt
new file mode 100644
index 0000000000..7650009e5e
--- /dev/null
+++ b/tests/auto/quick/pointerhandlers/qquickpointerhandler/CMakeLists.txt
@@ -0,0 +1,56 @@
+# Generated from qquickpointerhandler.pro.
+
+#####################################################################
+## tst_qquickpointerhandler Test:
+#####################################################################
+
+# Collect test data
+
+file(GLOB test_data_glob
+ LIST_DIRECTORIES true
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ "data/*")
+list(APPEND test_data ${test_data_glob})
+
+add_qt_test(tst_qquickpointerhandler
+ GUI
+ SOURCES
+ ../../../shared/util.cpp ../../../shared/util.h
+ ../../shared/geometrytestutil.cpp ../../shared/geometrytestutil.h
+ ../../shared/viewtestutil.cpp ../../shared/viewtestutil.h
+ ../../shared/visualtestutil.cpp ../../shared/visualtestutil.h
+ tst_qquickpointerhandler.cpp
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+ INCLUDE_DIRECTORIES
+ ../../../shared
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:qquickpointerhandler.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qquickpointerhandler.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"
+
+extend_target(tst_qquickpointerhandler CONDITION ANDROID OR APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\":/data\\\"
+)
+
+extend_target(tst_qquickpointerhandler CONDITION NOT ANDROID AND NOT APPLE_IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+)