aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickanimationcontroller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickanimationcontroller/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickanimationcontroller/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/auto/quick/qquickanimationcontroller/CMakeLists.txt b/tests/auto/quick/qquickanimationcontroller/CMakeLists.txt
new file mode 100644
index 0000000000..41dc23283e
--- /dev/null
+++ b/tests/auto/quick/qquickanimationcontroller/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Generated from qquickanimationcontroller.pro.
+
+#####################################################################
+## tst_qquickanimationcontroller Test:
+#####################################################################
+
+# Collect test data
+
+file(GLOB test_data_glob
+ LIST_DIRECTORIES true
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ "data/*")
+list(APPEND test_data ${test_data_glob})
+
+add_qt_test(tst_qquickanimationcontroller
+ GUI
+ QMLTEST
+ SOURCES
+ tst_qquickanimationcontroller.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:qquickanimationcontroller.pro:<TRUE>:
+# CONFIG = "qmltestcase"
+# TEMPLATE = "app"