aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickanimations/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickanimations/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickanimations/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/tests/auto/quick/qquickanimations/CMakeLists.txt b/tests/auto/quick/qquickanimations/CMakeLists.txt
index 6400a6b966..6a2541a247 100644
--- a/tests/auto/quick/qquickanimations/CMakeLists.txt
+++ b/tests/auto/quick/qquickanimations/CMakeLists.txt
@@ -5,15 +5,12 @@
#####################################################################
# Collect test data
-
-file(GLOB test_data_glob
- LIST_DIRECTORIES true
+file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "data/*")
+ data/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qquickanimations
- GUI
SOURCES
../../shared/util.cpp ../../shared/util.h
tst_qquickanimations.cpp
@@ -36,15 +33,11 @@ add_qt_test(tst_qquickanimations
)
#### Keys ignored in scope 1:.:.:qquickanimations.pro:<TRUE>:
-# CONFIG = "testcase"
# OTHER_FILES = "data/animationJobSelfDestructionBug.qml" "data/attached.qml" "data/badproperty1.qml" "data/badproperty2.qml" "data/badtype1.qml" "data/badtype2.qml" "data/badtype3.qml" "data/badtype4.qml" "data/disabledTransition.qml" "data/dontAutoStart.qml" "data/dontStart.qml" "data/dontStart2.qml" "data/dotproperty.qml" "data/Double.qml" "data/doubleRegistrationBug.qml" "data/fastFlickingBug.qml" "data/looping.qml" "data/mixedtype1.qml" "data/mixedtype2.qml" "data/nonTransitionBug.qml" "data/parallelAnimationNullChildBug.qml" "data/pathAnimation.qml" "data/pathAnimation2.qml" "data/pathAnimationInOutBackCrash.qml" "data/pathAnimationNoStart.qml" "data/pathInterpolator.qml" "data/pathInterpolatorBack.qml" "data/pathInterpolatorBack2.qml" "data/pathTransition.qml" "data/pauseBindingBug.qml" "data/pauseBug.qml" "data/properties.qml" "data/properties2.qml" "data/properties3.qml" "data/properties4.qml" "data/properties5.qml" "data/propertiesTransition.qml" "data/propertiesTransition2.qml" "data/propertiesTransition3.qml" "data/propertiesTransition4.qml" "data/propertiesTransition5.qml" "data/propertiesTransition6.qml" "data/propertiesTransition7.qml" "data/reanchor.qml" "data/registrationBug.qml" "data/reparent.qml" "data/rotation.qml" "data/runningTrueBug.qml" "data/scriptActionBug.qml" "data/scriptActionCrash.qml" "data/sequentialAnimationNullChildBug.qml" "data/signals.qml" "data/transitionAssignmentBug.qml" "data/valuesource.qml" "data/valuesource2.qml"
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qquickanimations.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qquickanimations CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"