aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquicklayouts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquicklayouts/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquicklayouts/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/auto/quick/qquicklayouts/CMakeLists.txt b/tests/auto/quick/qquicklayouts/CMakeLists.txt
new file mode 100644
index 0000000000..f750a4f1c5
--- /dev/null
+++ b/tests/auto/quick/qquicklayouts/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from qquicklayouts.pro.
+
+#####################################################################
+## tst_qquicklayouts Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ data/*)
+list(APPEND test_data ${test_data_glob})
+
+qt_add_test(tst_qquicklayouts
+ GUI
+ QMLTEST
+ SOURCES
+ tst_qquicklayouts.cpp
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:qquicklayouts.pro:<TRUE>:
+# OTHER_FILES = "data/tst_rowlayout.qml" "data/tst_gridlayout.qml" "data/tst_stacklayout.qml"
+# TEMPLATE = "app"