aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickopenglinfo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickopenglinfo/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickopenglinfo/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/tests/auto/quick/qquickopenglinfo/CMakeLists.txt b/tests/auto/quick/qquickopenglinfo/CMakeLists.txt
index a35670be38..bf366c2b7c 100644
--- a/tests/auto/quick/qquickopenglinfo/CMakeLists.txt
+++ b/tests/auto/quick/qquickopenglinfo/CMakeLists.txt
@@ -5,15 +5,12 @@
#####################################################################
# Collect test data
-
-file(GLOB test_data_glob
- LIST_DIRECTORIES true
+file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "data/*")
+ data/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qquickopenglinfo
- GUI
SOURCES
../../shared/util.cpp ../../shared/util.h
tst_qquickopenglinfo.cpp
@@ -26,15 +23,11 @@ add_qt_test(tst_qquickopenglinfo
)
#### Keys ignored in scope 1:.:.:qquickopenglinfo.pro:<TRUE>:
-# CONFIG = "testcase"
# OTHER_FILES = "data/basic.qml"
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qquickopenglinfo.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qquickopenglinfo CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"