aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickrectangle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickrectangle/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickrectangle/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/tests/auto/quick/qquickrectangle/CMakeLists.txt b/tests/auto/quick/qquickrectangle/CMakeLists.txt
index 8186d01e61..5653c08dd3 100644
--- a/tests/auto/quick/qquickrectangle/CMakeLists.txt
+++ b/tests/auto/quick/qquickrectangle/CMakeLists.txt
@@ -5,15 +5,12 @@
#####################################################################
# Collect test data
-
-file(GLOB test_data_glob
- LIST_DIRECTORIES true
+file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "data/*")
+ data/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qquickrectangle
- GUI
SOURCES
../../shared/util.cpp ../../shared/util.h
../shared/geometrytestutil.cpp ../shared/geometrytestutil.h
@@ -36,15 +33,9 @@ add_qt_test(tst_qquickrectangle
TESTDATA ${test_data}
)
-#### Keys ignored in scope 1:.:.:qquickrectangle.pro:<TRUE>:
-# CONFIG = "testcase"
-
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qquickrectangle.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qquickrectangle CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"