aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickrendercontrol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickrendercontrol/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickrendercontrol/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/quick/qquickrendercontrol/CMakeLists.txt b/tests/auto/quick/qquickrendercontrol/CMakeLists.txt
index 4015785def..90bfc57ebd 100644
--- a/tests/auto/quick/qquickrendercontrol/CMakeLists.txt
+++ b/tests/auto/quick/qquickrendercontrol/CMakeLists.txt
@@ -4,6 +4,12 @@
## tst_qquickrendercontrol Test:
#####################################################################
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ data/*)
+list(APPEND test_data ${test_data_glob})
+
qt_internal_add_test(tst_qquickrendercontrol
SOURCES
tst_qquickrendercontrol.cpp
@@ -14,6 +20,7 @@ qt_internal_add_test(tst_qquickrendercontrol
Qt::QmlPrivate
Qt::QuickPrivate
Qt::QuickTestUtilsPrivate
+ TESTDATA ${test_data}
)
#### Keys ignored in scope 1:.:.:qquickrendercontrol.pro:<TRUE>: