aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickspringanimation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickspringanimation/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickspringanimation/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/auto/quick/qquickspringanimation/CMakeLists.txt b/tests/auto/quick/qquickspringanimation/CMakeLists.txt
new file mode 100644
index 0000000000..4831c67c10
--- /dev/null
+++ b/tests/auto/quick/qquickspringanimation/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from qquickspringanimation.pro.
+
+#####################################################################
+## tst_qquickspringanimation Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ data/*)
+list(APPEND test_data ${test_data_glob})
+
+qt_add_test(tst_qquickspringanimation
+ SOURCES
+ ../../shared/util.cpp ../../shared/util.h
+ tst_qquickspringanimation.cpp
+ INCLUDE_DIRECTORIES
+ ../../shared
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ TESTDATA ${test_data}
+)
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_qquickspringanimation CONDITION ANDROID OR IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\":/data\\\"
+)
+
+qt_extend_target(tst_qquickspringanimation CONDITION NOT ANDROID AND NOT IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+)